Continuando com os algoritmos de repetição, vamos trabalhar a sintaxe do comando PARA.
Vimos, por exemplo, que para desenvolver um algoritmo que mostre os números de 1 a 10, utilizando o comando enquanto, resolvemos desta forma:

Var
x: inteiro
inicio
x <- 1
enquanto x <= 10 faca
escreval (x)
x <- x + 1
fimenquanto
fimalgoritmo.

Como já possuímos a informação que serão 10 números, ou seja, sabemos que temos um intervalor entre 1 e 10, podemos utilizar também o comando PARA. Com este comando não precisamos declarar a inicial constante e também não precisamos criar a linha do incremento (x<-x+1). Acompanhe:

Var
x: inteiro
inici
para x de 1 ate 10 faca
escreval (x)
fimpara
fimalgoritmo

Esta é a sintaxe do comando PARA, onde é necessário informar o intervalo dos números entra a variável e a expressão “ de …. até … faca”. Finalizando com a palavra fimpara.

Lembre-se: Podemos desenvolver um algoritmo onde será preciso ler a quantidade de dados que o usuário irá digitar. Inclusive esta informação é escolhida pelo próprio usuário antes da entrada de dados, isto torna o algoritmo mais flexível. Exemplo:

Desenvolver um algoritmo que mostre os números de 1 até um número qualquer determinado pelo usuário.

Var
x,n: inteiro
inicio
escreval (“Digite o limite da lista de números a serem mostrados na tela:”)
leia (n)
para x de 1 ate n faca
escreval (x)
fimpara
fimalgoritmo

Repare que incluímos um comando de leitura, ou seja, o usuário digitará o número de dados ( 1 ate n) que será mostrado.

  • Temos a variável n que receberá a informação.
  • Na linha para, n é o limite de números na tela.

    Dica – Repita este exemplo utilizando o comando Enquanto.

Tipo de variável lógica

O tipo lógico na condição do ENQUANTO tem aplicações específicas e pode ser uma alternativa para encerrar ou continuar um algoritmo, exemplo – VERDADEIRO ou FALSO.

Algoritmo ” VERDADEIRO ou FALSO”
Var
Teste : logico
Inicio
Teste <- verdadeiro
Enquanto teste faca
Escreval (“digite verdadeiro para continuar.”)
Leia (teste)
Fimenquanto
Escreva (“teste”)
Escreval (teste)
Escreval (“fim do teste!”)
Fimalgoritmo

Experimente desenvolver um algoritmo com comando para e uma variável lógica.

Outroe exemplo: Faça um algoritmo que exiba a tabuada de um número x conforme o exemplo abaixo, onde o usuário digitou 9. Veja o vídeo:

 

Desenvolva os algoritmos abaixo com os comandos de repetição:

  1. Escrever um algoritmo que leia o nome e o sexo de 5 pessoas, informe o nome e se a pessoa é homem ou mulher. No final informe total de homens e de mulheres.
  2. Desenvolva um algoritmo que leia 8 números e imprima estes números assim que for digitado;
    Exceto o úmero 5. Quando  x é igual a 5 a mensagem mostra:  O programa não mostra o número 5!
  3. Ler 5 números qualquer e em seguida informar quantos números estão no intervalo entre 5 e 50 inclusive.
  4. Faça um algoritmo que leia 10 números inteiros e, ao final, mostre a quantidade de números negativos que foram digitados.
  5. Faça um algoritmo que leia as seguintes informações de trinta pessoas: nome, idade, sexo e renda. Ao final exiba a quantidade de pessoas do sexo masculino, que tenha idade abaixo de 30 anos  e que tenha um rendimento acima de R$ 500,00.
  6. O IBGE realizou uma pesquisa com 3 torcedores que estiveram no jogo da copa 2014 (Brasil X Alemanha) e colheu a opinião sobre o time visitante. Cada torcedor respondeu questionário que solicitava os seguintes dados:
  • Idade do torcedor;
  • O número do ingresso do torcedor;
  • A opinião em relação à equipe da Alemanha – nota de 0 até 10.

Desenvolva um algoritmo que calcule e mostre como respostas as seguintes questões:

  • A quantidade de torcedores que deram a nota 10 para a equipe Alemã.
  • A média de idade dos torcedores que responderam o questionário.
  • O número do ingresso do torcedor mais velho.